BCD error displayed after selecting a PXE menu item
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BCD error displayed after selecting a PXE menu item

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Article ID: 163537

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Updated On:

Products

Deployment Solution

Issue/Introduction

You receive a BCD error after selecting a PXE menu item on a client system.

Steps taken to reach the error:

  1. Create a pxe preboot
  2. Boot client into pxe
  3. PXE menu shows up
  4. Select a preboot.  e.g winpe4
  5. BCD error is displayed

BCD error is shown on the screen

Environment

8.0 all versions

Cause

The customer installed the Windows 10 anniversary edition ADK and then created his winpe 4 and winpe 10 pxe preboots.

Resolution

Each version of WinPE uses a unique WinPE ADK.  If customers have installed the wrong ADK do the following on the NS:

If a preboot is created with the wrong ADK, open up 'prebootos.ini' at c:\program files\altiris\deployment\bdc\bootwiz and for each preboot you need to reinstall the ADK set 'Installed=False'.  For example:

  1. Open prebootos.ini
  2. Search for winpe40_x64
  3. Under winpe40_x64 looked for 'INSTALLED'
  4. Change 'INSTALLED=TRUE' to 'INSTALLED=FALSE'
  5. Save the file.

The system will now believe that no ADKs have not been installed and the approriate ADK can be installed for each WINPE version by following the steps below:

  1. Remove previous adk
  2. In the NS console go to 'Manage preboot configuration'
  3. Change to approriate preboot (e.g winpe4, winpe 10)
  4. Follow the instructions on the screen  
    1. Download  and install the adk
    2. Import the adk
  5. Create a new preboot.

 

NOTE:

For the appropriated ADK

Download the supported version that is supported for the version of ITMS that is installed as outlined in the TechDoc:

https://techdocs.broadcom.com/us/en/symantec-security-software/endpoint-security-and-management/it-management-suite/ITMS/Platform-and-OS-Support/deployment-solution-os-support-matrix-v132632614-d780e59066.html

Scroll down to section: Supported Windows Preboot Environments