Symantec Management Agent service crashes due to Patch Plug-in Upgrade (7.6.1645)
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Symantec Management Agent service crashes due to Patch Plug-in Upgrade (7.6.1645)

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Article ID: 163505

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Enabled the Symantec Management Agent (SMA) Upgrade policy and the SMA upgraded without errors; however, when the Software Update Plug-in (Patch Plug-in) Upgrade policy is enabled and received by the client; the SMA Service crashes.

Fatal error occured in module 'PatchMgmtAgents.dll (7.6.1645.0)' in 'AeXNSAgentHostSurrogate32.exe'.
Process ID: 4868
Thread ID: 6516
Context Record: 01CAF74C
Exception Record: 01CAF6FC
Exception Code: C0000005
Flags: 00000000
Address: 10028A93

EAX=01CAFBFC EBX=00735830 ECX=00000000 EDX=00000003 ESI=00000000
EDI=00735830 EBP=01CAFBD8 ESP=01CAFBB0 EIP=10028A93 FLG=00010206
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

Dump file: C:\ProgramData\Symantec\Symantec Agent\CrashDumps\AeXNSAgentHostSurrogate32_4868_6516_ITARCOL1172_2016-07-27_10-49-37.dmp.ez
-----------------------------------------------------------------------------------------------------
Date: 7/27/2016 4:49:44 AM, Tick Count: 7752235, Host Name: ITARCOL1172, Size: 807 B
Process: AeXAgentUtil.exe (2192), Thread ID: 6716, Module: AeXAgentUtil.exe
Priority: 1, Source: CrashControl

Environment

Patch Management Solution 7.6 HF6 with Software Update Plug-in v7.6.1645

Cause

PatchMgmtAgents.dll from Symantec Inc. has caused an access violation exception (0xC0000005) when trying to read from memory location 0x000001c4 on thread 7 

Resolution

Implement the attached PointFix to resolve this issue as follows:

  1. Log onto the SMP Server with Application Identity (Symantec Service Account) credentials.
  2. Save the attached PM_7.6_HF6_3980453_PointFix.zip to the SMP Server locally and decompress the folder.
  3. Open the folder, hightlight the PFInstaller.exe, right-click and run as Admin (the Symantec Service Account will update the necessary database items during this process).
  4. Open the Console > Settings > All Settings > Agents/Plug-ins > Software > Patch Management > Software Update Plug-in Upgrade policy; enable the policy and ensure the target houses the Clients moving forward.

Additionally, the following remedial steps was required as the steps above failed to resolve the issue:

  1. Uninstall the Software Update Plug-in by one of the following:
    • Enable the Software Update Plug-in Uninstall Policy and target the affected Clients from the Console > Settings > Agents/Plug-ins > All Agents/Plug-ins > Software > Patch Management 
    • Execute the CMD on the Client to uninstall agents:
      • Run AeXAgentUtil.exe /uninstallagents 
      • Additional CMDs outlined on HOWTO77405
         
  2. Delete the Registry Keys pertaining to Patch Management Solution:
    • Delete the key: HKey_Local_Machine\Software\Altiris\Altiris Agent\Patch Management
       
  3. Install the Software Update Plug-in
    • Enable the Software Update Plug-in Install Policy and target the affected Clients from the Console > Settings > Agents/Plug-ins > All Agents/Plug-ins > Software > Patch Management 

Advisory: The Client's Symantec Management Agent Service has stopped, so this implementation will not reach the Client if that is taking place, so an alternative method to deploy the updated Altiris_PatchMgmtAgent_Win32_7_6.msiAltiris_PatchMgmtAgent_Win_7_6.msi files to the affected clients via MSIExec, or by manually RDP to the affected Client and running the msi manually for that OS architect, or any other means to deploy / execute the msi to install the upgraded agent following the steps above.