Symantec Endpoint Protection client migration fails when using the client only patch
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Symantec Endpoint Protection client migration fails when using the client only patch

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Article ID: 163504

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Updated On:

Products

Endpoint Protection

Issue/Introduction

When migrating a Symantec Endpoint Protection client using a client only patch (delta), the migration fails with no visible error. The log for the patch installation is in the temp folder for the user than ran it %temp%\patch_inst.log or in C:\Windows\temp\patch_inst.log.

It will end with errors similar to the following:
08/02 09:38:36.796 [de8]  (LaunchXDeltaInternalAndWait) [3560] LaunchXDeltaInternalAndWait Error : xdelta returned non-zero result. Result: 1
08/02 09:38:36.796 [cf0]  (SymDelta::CXDeltaTool::Apply)     Return Code: 1
08/02 09:38:36.796 [cf0]  (SymDelta::CSymDelta::processDirs) ApplyDelta Operation failed.

Cause

This error is caused by the client not having the prior installation files cached in: 
C:\ProgramData\Symantec\Symantec Endpoint Protection\CurrentVersion\Data\Cached Installs

If this folder is empty or does not exist, this error will be encountered.

Resolution

If the cached install is missing, the migration will require a full client installation package be pushed to the client.