Restart Now fails to allow user to save work prior to rebooting the client
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Restart Now fails to allow user to save work prior to rebooting the client

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Article ID: 163390

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Reboot Popup presents an 'i' that details "You will be prompted to save your files when restarting." 

Cause

Previous versions allowed for a reboot countdown once the 'Restart Now' was selected; however, the updated Restart process in ITMS 8.0 doesn't allow for this added popup. 

This is a result of unification of the restart dialogs across all Solutions.

The 'countdown' was part of the restart notification process which was all encompassed; now that restart countdown is only seen in the 'Restart automatically after:' setting on the Default Software Update Plug-in Policy > Restart tab.

Resolution

Confirmed the operating system's 'Close Program' dark-opaque splash-screen is the process in which the work may be saved:

Caution: If Cancel is selected from the splash-screen; the Client will reboot within 15 minutes as noted in the lower right hand systray popup, and therefore saving work is manditory immediately after clicking Cancel if selected, for there will be no other warning popups following this timer:

Advisory: The Deferral Popup > 'Restart Now' commits to rebooting the Client by the end user, but if there is work to be saved then the splash-screen from Windows will display the ability to 'Force' or 'Cancel' the reboot. If the 'Cancel' option is selected; the agent is still in a rebooting state within the Operating System, so development is going to provide a more visible popup to replace the systray popup, and assist the end user in seeing that the reboot is incoming. This enhancement will be provided in ITMS 8.0 HF4.

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