Getting an error: "Index was outside the bounds of the array.Not enough storage is available to process this command. " while running a data collection job.
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Getting an error: "Index was outside the bounds of the array.Not enough storage is available to process this command. " while running a data collection job.

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Article ID: 163382

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Updated On:

Products

Control Compliance Suite Windows

Issue/Introduction

The error happens while collecting data from a target asset when the Locale of the CCS manager machine is set to Hungary.

Index was outside the bounds of the array.Not enough storage is available to process this command.

Cause

This issue will occur only with Hungarian Language settings at OS level with English version of CCS.
Hungarian supports multiple sorting orders. A sorting order controls the way programs sort characters and words. By default for Hungarian language settings have “DEFAULT” sorting method which sorts characters in Hungarian alphabetic order. Because we have English version of CCS, Hungarian sort order changes the way a program looks at the bit pattern of multibyte characters, thereby confusing string values.

Resolution

Here are all the steps to be performed to fix the issue.

1.   Change sorting order
•    Control Panel -> Clock, Language, and Region -> Language -> Change date, time, or number formats -> Additional settings ->Sorting -> Select the sorting method
•    Change the value from “Default” to “Technical”

Because language settings are applied at user level and not at OS level, step 1 will apply language setting to currently logged in user which almost always is not going to be CCS Manager Service context. Since CCS Manager runs under the Local System Account,  the above settings should have actually been applied to the Local System Account but because you cannot logon interactively to Local System Account. Follow step 2 to copy settings language to Local System Account.

2.   Copy language settings to “Local System Account”
•    Control Panel -> Clock, Language, and Region -> Language -> Change date, time, or number formats -> Administrative -> Copy Settings…
•    Select the “Welcome screen and system accounts” check box

3.    Restart CCS Manager Service.