"The Data could not be loaded" warning message is displayed when changing Software Delivery task target
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"The Data could not be loaded" warning message is displayed when changing Software Delivery task target

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Article ID: 163377

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Updated On:

Products

IT Management Suite

Issue/Introduction

You are trying to change targets in already existing Software Delivery task, "The Data could not be loaded" warning message is displayed in Symantec Management Console as seen here:

 

Following error can be found in SMP server (NS) logs:

"Unhandled error
Could not load the Software Component Superceds Software Component Resource Associations. Click menu: Settings->Security->Permissions. And select item: Settings->Notification \Server\Resource Associations\Software Management\
[Altiris.NS.Exceptions.AeXSecurityException @ Altiris.SoftwareManagementSolution]
at Altiris.SoftwareManagementSolution.Controls.DeliverSoftwareSelectorControl.GetSupercedes(IResource oSoftwareComponent)
at Altiris.SoftwareManagementSolution.Controls.DeliverSoftwareSelectorControl.UpdateSupercedes(IResource oSoftwareComponent)
at Altiris.SoftwareManagementSolution.Controls.DeliverSoftwareSelectorControl.SetPageValues(Guid guidSoftwareComponent)
at Altiris.SoftwareManagementSolution.ClientTasks.DeliverSoftwareExEditControl.SetInitialValues()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Exception logged from: 
at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
at Altiris.TaskManagement.UI.AltirisPageInstanceCachePage.OnAltirisPageInstanceCachePageError(Object sender, EventArgs e)
at System.Web.UI.Page.HandleError(Exception e)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest()
at System.Web.UI.Page.ProcessRequest(HttpContext context)
at Altiris.NS.UI.Controls.PageCachePage.ProcessRequest(HttpContext context)
at Altiris.NS.UI.AltirisPage.ProcessRequest(HttpContext context)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
at System.Web.HttpApplication.PipelineStepManager.ResumeSteps(Exception error)
at System.Web.HttpApplication.BeginProcessRequestNotification(HttpContext context, AsyncCallback cb)
at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context)
at System.Web.Hosting.PipelineRuntime.ProcessRequestNotificationHelper(IntPtr rootedObjectsPointer, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)
at System.Web.Hosting.PipelineRuntime.ProcessRequestNotification(IntPtr rootedObjectsPointer, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)
at System.Web.Hosting.UnsafeIISMethods.MgdIndicateCompletion(IntPtr pHandler, RequestNotificationStatus& notificationStatus)
at System.Web.Hosting.UnsafeIISMethods.MgdIndicateCompletion(IntPtr pHandler, RequestNotificationStatus& notificationStatus)
at System.Web.Hosting.PipelineRuntime.ProcessRequestNotificationHelper(IntPtr rootedObjectsPointer, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)
at System.Web.Hosting.PipelineRuntime.ProcessRequestNotification(IntPtr rootedObjectsPointer, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)

","Altiris.TaskManagement.UI.AltirisPageInstanceCachePage.OnAltirisPageInstanceCachePageError","w3wp.exe","87","Errors"

Environment

ITMS 8.x

Cause

Custom security role does not have sufficient permissions for the item.

Resolution

Try the following:

  1. Open Symantec Management Console and go to Settings > Security > Permissions and select the role (custom role) which is attached to the current account.
  2. Under "View" select Notification Server > Resources and Data Class Settings > Resource Associations > Software Management > Software Component Supersedes Software Component and check item permissions.
  3. Make sure it has at least "Read" permissions.