Discover scans of Oracle Databases may fail with Timezone Region Not Found errors
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Discover scans of Oracle Databases may fail with Timezone Region Not Found errors

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Article ID: 163369

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Updated On:

Products

Data Loss Prevention Endpoint Prevent Data Loss Prevention Network Monitor Data Loss Prevention Network Prevent for Email Data Loss Prevention Enforce Data Loss Prevention Network Discover Data Loss Prevention Network Prevent for Web Data Loss Prevention Network Protect Data Loss Prevention Endpoint Discover

Issue/Introduction

Discover scans of Oracle Databases may fail with "Timezone Region Not Found" errors. This issue is observed on Red Hat Enterprise Linux 6.5 systems.

Reason: ORA-00604: error occurred at recursive SQL level 1 ORA-01882: timezone region not found.

Cause

This issue is caused by a difference in behavior between ojdb6 and ojdbc7. If the time zone of the Enforce or Detection server is not available in the target's
Oracle repository table V$TIMEZONE_NAMES, the connection fails with the error specified above.

Resolution

To resolve this issue, set your desired time zone on each Enforce and Detection server, then create a symlink called "localtime" that points to the desired time zone file. Restart your Symantec DLP services to apply your changes.

  1. On each Enforce and Detection server in your deployment, locate the time zone file you want in the /usr/share/zoneinfo directory. For example, /usr/share/zoneinfo/America/Los_Angeles.
  2. Open /etc/sysconfig/clock and set ZONE="<your_time_zone>". For example, ZONE="America/Los_Angeles”.
  3. Create a symlink in the /etc directory called "localtime" that points to your desired timezone in the /usr/share/zoneinfo directory. For example, ln -sf /usr/share/zoneinfo/America/Los_Angeles /etc/localtime.
  4. Restart the Symantec DLP services on your Enforce and Detection servers to apply your changes.