Windows Compliance By Computer Report Shows inaccurate compliance numbers
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Windows Compliance By Computer Report Shows inaccurate compliance numbers

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Article ID: 163349

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Viewed the Windows Compliance By Computer report; found extremely high Software Update count totals in Patch Management Solution 8.0, 8.0 HF1 and 8.0 HF2. Additionally, found drill-downs display conflicting counts to those displayed on the main report.

Highlighted affected Client in the returned data, right-click > View (View Applicable Updates, View Installed Updates, and View Not Installed Updates); found the numbers display accurately displays more accurate counts.

Appears the problem only occurs for Clients reporting a reboot is pending.

Cause

Confirmed the spPMWindows_ComplianceByComputer is utilizing a left join that is causing the results to render with all Software Updates until the Client is rebooted.

Resolution

This issue has been resolved in 8.0 HF3 - See release notes for more information DOC9378

Implement the PointFix by working through the following steps in the SQL Server Management Studio:

  1. Under Object Explorer: Expand the SQL instance > Symantec_CMDB > Programmability > Stored Procedures; right-click on this folder > Filter > Filter Settings, and input the following under Value: spPMWindows_ComplianceByComputer.
     
  2. Highlight the Stored Procedure in the left pane; dbo.spPMWindows_ComplianceByComputer > right-click > rename, and add the .old extension as follows:

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  3. Copy the attached 'spPMWindows_ComplianceByComputer_Fix.sql' file to the SQL Server Management Studio; execute the SQL script to implement the updated Stored Procedure and should appear as follows:
  4. The report should render using the updated Stored Procedure and the issue should be resolved.

Attachments

spPMWindows_ComplianceByComputer_Fix.sql get_app