After a repair via AeXConfig.exe on the SMP, multiple errors regarding "Procedure or function sp<name> has too many arguments specified" started to appear.
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After a repair via AeXConfig.exe on the SMP, multiple errors regarding "Procedure or function sp<name> has too many arguments specified" started to appear.

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Article ID: 163331

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Updated On:

Products

IT Management Suite

Issue/Introduction

Customer ran a repair via AeXConfig.exe /configure using some config files. After that errors like these started to appear in the NS logs. For example:

                Item save to DB failed: 5b8b13d1-d5f1-4a06-a80f-42252f82e19e, Failure in save for Resource item. [Procedure or function spResourceSetKeys has too many arguments specified.]
            Procedure or function spResourceSetKeys has too many arguments specified.
 
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NSE dispatch failed for: id=162010662, from: 2a9b9ed5-f87f-45b4-9da0-b7cc21a6d4c3, to: 'Inventory Solution Capture Item'
Failure in save for Resource item. [Procedure or function spResourceSetKeys has too many arguments specified.]
 
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            Failed to save messaging resource: 'uspdxrad4509' (a476b125-0763-4206-949b-b9bff8d998fb)
Failure in save for Resource item. [Procedure or function spResourceSetKeys has too many arguments specified.]

 

Cause

In this particular scenario, the customer had version ITMS 8.0 HF1 installed. Running .config files directly may cause that the original version of some stored procedures to roll back to the default 8.0 version rather than the 8.0 HF1.

For example, running aexconfig /configure "C:\Program Files\Altiris\Notification Server\Config\CoreSolution.config" should bring the main components for the SMP configured, but in order to get the Hotfix version of the stored procedures, it is usually necessary to run as well NS_Update.config and/or NS_Hotfix.config in order to get the updated versions in place as well.

Resolution

In most cases this issue can be fixed by one of the following steps:

Option 1. Run a repair on the latest Hotfix installed via SIM. In most cases, depending on what Solution owns/updated the stored procedure, runnig the repair on the Symantec Management Platform should be sufficient (or the Solution that updated the stored procedure).

Option 2. Run aexconfig /configure "C:\Program Files\Altiris\Notification Server\Config\CoreSolution.config" and after it run as well:
aexconfig /configure "C:\Program Files\Altiris\Notification Server\Config\NS_Update.config"
aexconfig /configure "C:\Program Files\Altiris\Notification Server\Config\NS_Hotfix.config"


Option 3. Grab the newest version of the stored procedure from another SMP installation's database. After finding the stored procedure under the left-tree in SQL Management Studio, use Right-click>Script Stored Procedure as>Alter to>New query Editor Window and use the query that is been created. Or you can find the query under NS_Hotfix_SqlObjects.config and change the CREATE command to ALTER.