Failed to setup performance counters.
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Failed to setup performance counters.

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Article ID: 163243

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Updated On:

Products

IT Management Suite

Issue/Introduction

Repeatedly getting the following error related to Performance Counter in the Altiris Log Viewer logs:

Database counters failed to validate, recreating.
Process: AtrsHost (3880), Thread ID: 27, Module: AtrsHost.exe Priority: 2, Source: Altiris.TaskManagement.Performance.DeadlockPerformanceCounter.Validate File: C:\ProgramData\Symantec\SMP\Logs\a.log Failed to setup performance counters. The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly. [System.InvalidOperationException @ System] at System.Diagnostics.PerformanceCounter.InitializeImpl() at System.Diagnostics.PerformanceCounter..ctor(String categoryName, String counterName, String instanceName, Boolean readOnly) at System.Diagnostics.PerformanceCounter..ctor(String categoryName, String counterName, Boolean readOnly) at Altiris.ClientTask.Server.RemoteClientTaskManager.PerformanceCounterInstaller()

Environment

ITMS 8.x

Cause

This behavior may occur if certain extensible counters corrupt the registry, or if Windows Management Instrumentation (WMI) based programs modify the registry.

Resolution

Please refer to the following Microsoft KB article for details and follow those suggestions:

https://support.microsoft.com/en-us/kb/2554336 

  • Verify if counters are disabled via registry key
    • HKLM\System\CurrentControlSet\Services\%servicename%\Performance
  • Then rebuild Performance Counters with lodctr /R command if required