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Unknown error is thrown when attempting to Save result as report for Installed Products

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Article ID: 163195

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Updated On:

Products

IT Management Suite

Issue/Introduction

Browsing under Manage > Software > Installed Products, selecting any of the displayed Software, under Computers with software installed click on Save result as report. When selecting the option to "Save as Report" and "open report in new window after saving" the error: Unknown error is thrown.

The following errors are found in the a.log files when the above action is attempted:

Error 1:
Failed to resolve resource query from the xml configuration. This join source does not have a dataField 'ResourceGuid' [Altiris.NS.Exceptions.AeXException @ Altiris.Reporting.DataSource]

Error 2:
GetSearchSql failed: Failed to resolve resource query from the xml configuration. [Altiris.DataSource.Exceptions.DataSourceQueryResolveException
This join source does not have a dataField 'ResourceGuid' [Altiris.NS.Exceptions.AeXException @ Altiris.Reporting.DataSource]

Error 3:
Failed to save report as legacy report.  Failed to resolve resource query from the xml configuration. [Altiris.DataSource.Exceptions.DataSourceQueryResolveException
This join source does not have a dataField 'ResourceGuid'

Error 4:
Page Error. Failed to get the report item '00000000-0000-0000-0000-000000000000' for reading.

Cause

This is a known issue when Asset Management Solution is not installed.

Resolution

This issue has been resolved in 8.0 HF2 - See release notes for more information DOC9343

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