Installation Manager is unable to launch after upgrade. Getting "Product listing is null - failed to read Xml file"
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Installation Manager is unable to launch after upgrade. Getting "Product listing is null - failed to read Xml file"

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Article ID: 163158

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Updated On:

Products

IT Management Suite

Issue/Introduction

Unable to launch SIM (Symantec Installation Manager). The SIM logs shows the following errors:

Product listing is null - failed to read Xml file 'D:\Program Files\Altiris\Symantec Installation Manager\Installs\Altiris\symantec_v2.pl.xml.zip'.
 
Failed to load Product Listing Xml file 'D:\Program Files\Altiris\Symantec Installation Manager\Installs\Altiris\symantec_v2.pl.xml.zip'.
 

Error 1:
Failed to parse product listing XML from file 'C:\Users\Svc_AltirisII\AppData\Local\Temp\3\tmp3DF7.tmp\symantec_v2.pl.xml'.
'product' element has unexpected attribute 'HierarchyAllowMode'.
 
Error 2:
Failed to load Product Listing Xml file 'D:\Program Files\Altiris\Symantec Installation Manager\Installs\Altiris\symantec_v2.pl.xml.zip__tmp'.

Error 3:
Failed to parse product listing XML from file 'C:\Users\Svc_AltirisII\AppData\Local\Temp\3\tmp2EF3.tmp\symantec_v2.pl.xml'.
'product' element has unexpected attribute 'HierarchyAllowMode'.

Environment

ITMS 8.x

Cause

In this particular instance, SIM was pointing to the wrong installation drive referenced in the registry.

Resolution

In order to fix this issue make sure the following regkeys have the proper drive references:

HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\InstallDir
HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\PackageRepositoryPath
HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\PlatformInstallDir
HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\NsConfiguration\InstallPath
HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\ProductListings\Destination
HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\ProductListings\0\Source

Note: If SIM has another PL location specified under Settings, check under HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\ProductListings\Current. If it is 1, then verify:

HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\ProductListings\1\Source for example