search cancel

Altiris agent logs show Warning: EvaluateExpressionNode_msiProductInstalled

book

Article ID: 163149

calendar_today

Updated On:

Products

Inventory Solution

Issue/Introduction

Warning appear in agent logs whenever a Targeted Software Inventory (TSI) runs while no user is logged on to the target PC. This occurs when the TSI uses a detection check that includes checking the MSI product code and the Detect per-user installation option is enabled.

EvaluateExpressionNode_msiProductInstalled- no logged on user found to impersonate: The operation being requested was not performed because the user has not logged on to the network. The specified service does not exist (-2147023651)

Cause

TSI uses a detection check that looks for the MSI product code and the “Detect per-user installations for the interactive user” option is enabled. However the TSI schedule Advanced options are not configured to run with the option: Only perform check if a user is logged on to the computer. 

Resolution

Go to the Advanced options in the TSI schedule and enable Only perform check if a user is logged on to the computer.