Installed products do not show as configured in the SIM tool
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Installed products do not show as configured in the SIM tool

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Article ID: 163072

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Updated On:

Products

IT Management Suite

Issue/Introduction

You are having a hard time getting SIM to show correctly what is configured. When SIM launches, it shows that all products as installed but not configured.

If you run a reconfigure via SIM, it finishes and everything is fine (everything appears as configured). But if you close and reopen SIM you get back to the same not configured state.

When SIM loads again everything appears and a reconfiguration is needed.

In the NS logs you may see the following warning/messages (any of one of these):

Message 1:
The following error occurred while querying for configured products. This is normal if this is an initial installation of the NS/Platform: Error querying DB. Altiris.NS.ContextManagement.DatabaseContext could not be loaded.
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Process: SymantecInstallationManager (7840), Module:SymantecInstallationManager.exe
Source: Symantec.Installation.Managers.ProductListingManager.SetInstalledProducts

Message 2:
Exception: Timeout expired. The timeout period elapsed prior to obtaining a connection from the pool. This may have occurred because all pooled connections were in use and max pool size was reached.
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Process: SymantecInstallationManager (36220), Module: SymantecInstallationManager.exe
Source: Symantec.Installation.SQLAuth.GetProductGuidsOfConfiguredItems

Message 3:
GetProductGuidsOfConfiguredItems failed
Connection Timeout Expired.  The timeout period elapsed while attempting to consume the pre-login handshake acknowledgment.  This could be because the pre-login handshake failed or the server was unable to respond back in time. 
The duration spent while attempting to connect to this server was - [Pre-Login] initialization=21030; handshake=1; 

Environment

ITMS 8.x

Cause

Environmental, and most likely network latency. In this particular situation the communication between the SMP and SQL servers was delayed.

SIM's first attempt to establish a connection was too slow in getting a response from the SQL server.

Most of the SMP code has multiple SQL connection retry logic in it. However with SIM, any retry logic is very limited. In order to overcome these environmental constraints, SIM required some adjustments in the SQL Connection Creation code.

Resolution

Broadcom's Dev team has added the following changes into the SQL Connection Creation code in order to bypass this network latency.

  • Added 5 retries that will be performed with some delay (default 5 sec, can be overridden from registry)
  • Added ability to override default connection creation timeout

New regkeys were also created for SIM SQL Connection Creation:

  • Under HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM create DWORD "DBRetryTimeout" and set it to 15 (time out between retries in seconds).
  • Under HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM create DWORD "DBConnectionTimeout" and set it to 120 (connection creation timeout in seconds)