search cancel

Altiris Inventory Agent removes Altiris Server Inventory Agent during install/upgrade

book

Article ID: 163031

calendar_today

Updated On:

Products

Endpoint Encryption Inventory Solution

Issue/Introduction

A recent upgrade from 7.5 -> 7.6 results in the Server Inventory Plug-in to be removed when upgrading the Inventory Agent. This leaves the server without the Inventory Pack for Servers Plug-in. This requires the computer to be targeted, have the software downloaded and then installed using the Inventory Pack for Servers Plug-in Install policy.

Cause

This is by design, and is due to the legacy Inventory Plugins (Altiris Inventory Plug-in, Altiris Server Inventory Plug-in, and Application Metering Plug-in) being x86 architecture, and the new 7.6 versions are x64 so the install/upgrade of the Inventory Agent Plug-in removes the legacy server plugin.

Resolution

This issue is fixed in 7.6 HF3. The current workaround is to enable the Server Inventory Plug-in Install policy (And Application Metering, if necessary) to (re)install this x64 version of the plug-ins.