search cancel

Tablespace Errors in simdbmu.log after fresh install

book

Article ID: 163029

calendar_today

Updated On:

Products

Security Information Manager

Issue/Introduction

After a fresh install of SSIM 4.8.1 there are tablespace and index errors in simdbmu.log.

The Table or Index in the error will vary, but below is an example:

2015-08-22 19:44:27,598 201304143 [DBMU-1] WARN  com.symantec.sim.simdb.job.BaseHealthJob - incident - Caught exception during doQuickRunstats for table SYMCMGMT.SYMC_SIM_POLICY
com.symantec.sim.simdb.utils.sql.SimDbTableOrIndexDoesNotExistException: Table or index does not exist: CallableStatementCallback; nested exception is com.ibm.db2.jcc.am.SqlException: DB2 SQL Error: SQLCODE=-2306, SQLSTATE=     , SQLERRMC=SYMCMGMT.SYMC_SIM_POLICY, DRIVER=3.63.75

Cause

The appliance SSIM is being installed to is a Single Disk install but also has a device showing during boot which udev is identifying as a second disk.

Because of this the installer thinks it is a Two Disk install and there for tries to setup DB2 on the second disk but fails.

Resolution

Ensure no external storage devices are connected via USB such as a "Thumb Drive" or External Hard Drive.

For the following you must have console access to the hardware system or a Remote Console capability.

  • Boot into the BIOS and ensure no Virtual Items are enabled/listed such as a Virtual CD-ROM or Virtual Floppy.
  • If the system has Remote Console capability which allows Virtual Media to be setup, ensure the virtual media is set to "Detached". 
    Even if the Virtual Media feature is disabled.

After confirming none of the above situations exist or they are removed/disabled, install SSIM.