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Reinstalling a Ghost Solution Suite 3.0 hotfix prompts to repair instead of install

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Article ID: 162987

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

You have uninstalled GSS 3.0 and now are reinstalling to the same system.  After installing GSS 3.0 you attempt to apply the latest hotfix.  When the hotfix installer is ran you receive a dialog prompting a repair instead of the usual install dialog.

Cause

The product installer key in the registry left behind from the previous install of the hotfix has the Windows Installer believe the hotfix is already(still) installed.

Resolution

Deleting the appropriate registry key then running the hotfix installer will allow for a normal install. See the below registry keys and their corresponding hotfix(HF).

HF3 - HKEY_CLASSES_ROOT\Installer\Products\92BEDBA7ABC30CC44A3B580843BD5CF9

HF4 - HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\243C1AB6F71E42249B288E6BD7CDCA91

HF5 - HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\2EA2F29838C8CB944BF3DED50A82B317

 

Additionally, you can search HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\ for the string 'Symantec Ghost Solution Suite 3.0' to find any of the HF product codes.