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SonicWall Blocking PMImport on AexPatchAssesment.exe

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Article ID: 162774

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

SonicWall firewall anti virus software is blocking the AexPatchAssesment.exe on download via the PMI. Detects as Dropper.FIY

"failed to update tools\AexPatchassessment.exe Data hash does not match"

Some errors also found associated to the AeXPatchAssessmentSrv.exe

Cause

SonicWall detects the AexPatchAssesment.exe and/or AeXPatchAssessmentSrv.exe as a Trojan and excludes it from download and the Import Patch Data for Windows fails.

To confirm cause: Input the following URL into a browser on the SMP Server and it will fail with the attached screen shot: www.solutionsam.com/imports/7_1/patch/windows/tools/aexpatchassesments.exe

Resolution

Please contact Sonicwall to have this file included/whitelisted as a valid/safe file.

Workaround: Run NSlookup on the SMP Server for 'www.solutionsam.com' and that will provide the current IP that the SMP Server will be pulling from. Advisory: The SolutionSam.com site is managed on Akamai Server Farm and this IP is dynamic, so the process may need to be repeated as the IP may change pending download region and time.

Attachments

sonicwall.png get_app