search cancel

"The certificate used to identify this application has expired." appears when trying to create or update a package

book

Article ID: 162748

calendar_today

Updated On:

Products

Software Management Solution

Issue/Introduction

Starting December 1st 2015, a prompt appears stating certificate has expired when using java based package importer in the console.

This would happen any time the package editor/creator is brought up for any Software Resource.

Cause

The certificate of PackageDefinition.jar expired  December 1, 2015.

Resolution

The certificate has been updated as of Software Management 7.6 HF7. To no longer see this prompt, upgrade to this version or newer.

If you are unable to upgrade, you can add your SMP to your java Exception Site List to be able to proceed past the warning. This will not prevent the warning from appearing, however. This exception will have to be added on any endpoint that uses the console. To add the exception, open your Java Control Panel and click the Security tab, and click Edit Site List at the bottom left, then add your SMP server http path to the list (http[s]://[SMPname]/Altiris):

Attachments