search cancel

Getting message 'Error saving event (file: ): The system cannot find the path specified. (0x80070003)'

book

Article ID: 162681

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

Customer noticed that in his Agent logs the following messages were present:

Error saving event (file: ): The system cannot find the path specified. (0x80070003)

and

The system cannot find the path specified. (0x80070003)

When a NSE is been sent, the actual file is created but not sent to the SMP.

Entry 1:

AeXNSEvent class created
-----------------------------------------------------------------------------------------------------
Date: 12/4/2015 12:43:16 PM, Tick Count: 10216099 (02:50:16.0990000), Size: 262 B
Process: AexPatchAssessment.exe (6476), Thread ID: 5744, Module: AeXNSEvent.dll
Priority: 8, Source: AeXNSEvent

 

Entry 2:

Error saving event (file: ): The system cannot find the path specified. (0x80070003)
-----------------------------------------------------------------------------------------------------
Date: 12/4/2015 12:43:18 PM, Tick Count: 10218627 (02:50:18.6270000), Size: 336 B
Process: AeXNSAgent.exe (3592), Thread ID: 7156, Module: AeXNSAgent.exe
Priority: 2, Source: CoEventTransport::raw_SendQueued

 

Entry 3:

The system cannot find the path specified. (0x80070003)
-----------------------------------------------------------------------------------------------------
Date: 12/4/2015 12:43:18 PM, Tick Count: 10218627 (02:50:18.6270000), Size: 309 B
Process: AexPatchAssessment.exe (6476), Thread ID: 5744, Module: AeXNSEvent.dll
Priority: 2, Source: AeXNSEvent::raw_SendQueued

 

Entry 4:

AeXNSEvent class created
-----------------------------------------------------------------------------------------------------
Date: 12/4/2015 12:43:18 PM, Tick Count: 10218658 (02:50:18.6580000), Size: 254 B
Process: AeXNSAgent.exe (3592), Thread ID: 1672, Module: AeXNSEvent.dll
Priority: 8, Source: AeXNSEvent

 

Entry 5:

Failed to read item, error: The system cannot find the file specified (0x00000002)
-----------------------------------------------------------------------------------------------------
Date: 12/4/2015 12:43:18 PM, Tick Count: 10218658 (02:50:18.6580000), Size: 315 B
Process: AeXNSAgent.exe (3592), Thread ID: 7172, Module: AeXAgentExt.dll
Priority: 8, Source: AgentStorage

 

 

Cause

This issue is caused usually by having too many *.tmp files under C:\Windows\Temp. We use this location in order to compress/uncompress the NSE files. Having too many files can cause a file collision or unsufficient resources to create the file.

Windows API should be cleaning up this directory everytime after the files has been used but in this particular instance it didn't happen.

Resolution

Go to C:\Windows\Temp directory and delete old *.tmp files that you find.