Getting message 'Error saving event (file: ): The system cannot find the path specified. (0x80070003)'
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Getting message 'Error saving event (file: ): The system cannot find the path specified. (0x80070003)'

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Article ID: 162681

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Updated On:

Products

IT Management Suite

Issue/Introduction

You noticed that in his Agent logs the following messages were present:

"Error saving event (file: ): The system cannot find the path specified. (0x80070003)"

"The system cannot find the path specified. (0x80070003)"

When a NSE is been sent, the actual file is created but not sent to the SMP.

Entry 1:

AeXNSEvent class created
-----------------------------------------------------------------------------------------------------
Process: AexPatchAssessment.exe (6476), Thread ID: 5744, Module: AeXNSEvent.dll
Priority: 8, Source: AeXNSEvent

Entry 2:

Error saving event (file: ): The system cannot find the path specified. (0x80070003)
-----------------------------------------------------------------------------------------------------
Process: AeXNSAgent.exe (3592), Thread ID: 7156, Module: AeXNSAgent.exe
Priority: 2, Source: CoEventTransport::raw_SendQueued

Entry 3:

The system cannot find the path specified. (0x80070003)
-----------------------------------------------------------------------------------------------------
Process: AexPatchAssessment.exe (6476), Thread ID: 5744, Module: AeXNSEvent.dll
Priority: 2, Source: AeXNSEvent::raw_SendQueued

Entry 4:

AeXNSEvent class created
-----------------------------------------------------------------------------------------------------
Process: AeXNSAgent.exe (3592), Thread ID: 1672, Module: AeXNSEvent.dll
Priority: 8, Source: AeXNSEvent

Entry 5:

Failed to read item, error: The system cannot find the file specified (0x00000002)
-----------------------------------------------------------------------------------------------------
Process: AeXNSAgent.exe (3592), Thread ID: 7172, Module: AeXAgentExt.dll
Priority: 8, Source: AgentStorage

 

 

Environment

ITMS 7.x, 8.x, 8.7.x

Cause

This issue is caused usually by having too many *.tmp files under C:\Windows\Temp.

We use this location in order to compress/uncompress the NSE files. Having too many files can cause a file collision or insufficient resources to create the file.

Windows API should be cleaning up this directory every time after the files has been used but in this particular instance it didn't happen.

Resolution

Go to "C:\Windows\Temp" directory and delete old *.tmp files that you find.