search cancel

Upgrading Enforce server DLP 14 to 14.0.1 failed

book

Article ID: 162659

calendar_today

Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

 While upgrading to version 14.0.1, during the Enforce server portion the upgrade stopped with an error on the following file: "could not delete C:\SymantecDLP\Protect\updates\update-id-12152\..\..\tomcat\webapps\ProtectManager\WEB-INF\lib\manager.jar"

The Oracle database was upgraded successfully but not the Enforce server.   When re-attempting the update it states that Enforce is already updated and will be skipped.  Although login to the UI Console fails, it does display a login prompt but the graphics are missing and clicking on the login button does nothing.

Error: "Could not delete C:\SymantecDLP\Protect\updates\update-id-12152\..\..\tomcat\webapps\ProtectManager\WEB-INF\lib\manager.jar"

Cause

Failure to delete the listed file, would not allow the Enforce server to finish it's upgrade.

Resolution

Restore the file from backup, and restart the Vontu services and then login into the UI for administration.  Also use the Installation Guide to verify the schema and file structure (page 36) in order verify the upgrade & restoration.

Attachments

Symantec_DLP_14.0_Install_Guide_Win.pdf get_app