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SEE DE policy not being enforced in Dell Latitude E7440 - Disk Samsung PM851 SSD

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Article ID: 162555

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Updated On:

Products

Endpoint Encryption

Issue/Introduction

SEE DE policy is not enforced - no user registration, no assistant to create Self Recovery questions prompted, etc.
Disk not showing up in SEE MA as an internal drive either.
 

Generally speaking, no error pops up. User registration or drive encryption is not occurring.
When issuing eedadmincli, enum via command line, the following error is displayed:
Failed to initialize disks:
The boot disk might not be encrypted or the encryption record might be damaged.
To locate and repair the record, please use --recover-disk option

Cause

Some Dell Latitude models are shipped with SATA controller set to RAID and there is no Rapid Storage controller installed at all.

Environment

  • SEE 11.0.X (SEE MA and SEE DE 11.0.x)
  • Computer make and model: Dell Latitude E7440
  • OS: WIndows 7 x32bit
  • Disk make and model: Samsung SSD PM851
  • BIOS and other drivers updated

Resolution

The following steps help to workaround the issue

  1. At BIOS level. Change the SATA controller from RAID to AHCI
    1. Before applying the change, though, it is advisable to go thru the Microsoft KB 922976 to ensure the AHCI drivers are enabled.
      1. https://support.microsoft.com/en-us/kb/922976
  2. Install Rapid Storage controller from Dell official site
    1. http://www.dell.com/support/home/us/en/04/product-support/product/latitude-e7440-ultrabook/drivers/advanced
    2. As a dependency install, it may be needed to install/update .Net Framework 4.5.X before installing/upgrading the Rapid Storage controller.
  3. Install SEE MA and SEE DE