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Control Compliance Suite Data Processing Service fails to start on the CCS Manager

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Article ID: 162509

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Updated On:

Products

Control Compliance Suite Control Compliance Suite Standards Module Control Compliance Suite Standards Server

Issue/Introduction

Control Compliance Suite (CCS) Data Processing Service fails to start on the CCS Manager.

While we try to start the said service from the Services Microsoft Management Console (MMC) it pops up a message-"Service Started and then stopped"

While we try to start the said service from the Services Microsoft Management Console(MMC) it pops up a message-"Service Started and then stopped"

Windows Event Viewer shows the following event/error details-
Could not find ESM Manager service port in configuration file
'<Install Dir>:\Program Files (x86)\Symantec\CCS\ESM\config\tcp_port.dat'.
Service cannot be started.
System.ApplicationException: Could not find ESM Manager service port in configuration file
'<Install Dir>:\Program Files (x86)\Symantec\CCS\ESM\config\tcp_port.dat'.

Cause

Either the 'tcp_port.dat' file is missing at the following location-
'<Install Dir>:\Program Files (x86)\Symantec\CCS\ESM\config'
or
The following registry key is pointing to an incorrect path for "ESMDirectory" String Value -
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Symantec\ESM\12.5

Resolution

  • If 'tcp_port.dat' file is missing then perform a repair install of the CCS Manager, it should restore the missing components.
  • Secondly verify the path of "ESMDirectory" String Value at the following registry key-

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Symantec\ESM\12.5

ESM Directory "String Value" path should be-'<Install Dir>:\Program Files (x86)\Symantec\CCS\Reporting and Analytics\ESM'

  • Once the above steps are performed try restarting the Symantec Data Processing Service again.
  • It should start normally now.

NOTE:

  • If a repair fails or the registry key is missing.  It is recommended to restore from backup to a known good state. Or if not available or not possible, then uninstall/reinstall the CCS Manager.
  • If this is the CCS Manager on the Application Server make sure to take a backup of the 3 following config files in the <Install Dir>\CCS\Reporting and Analytics\DPS\ folder. As these may be required in order to uninstall/reinstall.
  • Blade.WorkerProcess.exe.config
  • Blade.WorkerProcess.x64.exe.config
  • Symantec.CSM.DPS.exe.config

Additional Information

Note: This generally is caused using the agent only installer to install the standalone agent on the CCS Manager. 

While the full installset installer will prevent the standalone agent from being installed.  The newer agent installs do not have that same check and will install over stop of the Manager, which will update the registry keys.
This will cause a number of issues.