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Cannot create an information incident for messages with double-byte character encodings

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Article ID: 162508

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Messages with double-byte character encodings (such as emoji) cannot be delivered to the Control Center as an informational incident. Delivery fails and the messages remain in the delivery queue until they are bounced with a delivery status notification.

The Message Audit Logs show a delivery failure: 421 closing connection

The BrightmailLog.log Control Center log file shows exceptions during each delivery attempt:


Oct 18 2015 17:43:16 [SmtpWorker-7] [MailHandler] ERROR - can't publish spam message
com.symantec.smg.controlcenter.internal.dataaccess.DataAccessException: The text entered uses an encoding system that is not currently supported. Please rewrite the text. ; nested exception is:
     java.sql.SQLException: Incorrect string value: '\xF0\x9F\x9A\x97 S...' for column 'subject' at row 1

Cause

Messages with 4-byte UTF-8 Unicode encoded characters in the subject line (possibly elsewhere as well) cannot be stored in database as informational incidents.

Environment

Messaging Gateway 10.5
Messaging Gateway 10.6

Resolution