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Is there a way in SMG to prevent email loop caused by auto-reply to invalid address?

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Article ID: 162405

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Example of message audit log:
Message-ID: <[email protected]<sender-domain.com>
Accepted From: x.x.x.x (Logical IP =  x.x.x.x )
Scanners: SMG Scanner
Time accepted: Saturday, Feb 07, 2015 11:31:33 AM
Direction: Inbound
Sender: (none)
Authenticated username: (none)
Original recipients: [email protected]<recipient-domain.com>
Original Subject: mail delivery failed: returning message to sender Message Size: 6 KB
Identified attachment(s): None
 

Cause

Auto-reply is configured on the client machines. When auto-reply is sent to an invalid email address, email loop is encountered. This can only be stopped once auto-reply is disabled.

Resolution

This issue is due to the auto reply configured on the client machines and not with SMG.

The workaround in SMG is to block emails without senders using a compliance rule http://www.symantec.com/business/support/index?page=content&id=TECH94058 but the fix should be done on the Exchange server itself.

Exchange should prevent autoforward rules from running against any message that contains an empty RFC 821 FROM field. You may refer to http://support.microsoft.com/kb/238429.  Please contact Microsoft support if you have further concerns on this.