Upgrade or Installation of Endpoint Protection fails with error Failed to open service. winerror = 1060 or Failed to open key. winerror = 2 in SIS_Inst.log
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Upgrade or Installation of Endpoint Protection fails with error Failed to open service. winerror = 1060 or Failed to open key. winerror = 2 in SIS_Inst.log

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Article ID: 162364

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Updated On:

Products

Endpoint Protection

Issue/Introduction

Upgrade or installation of Symantec Endpoint Protection (SEP) fails

in SIS_Inst.log:

2015-09-10T11:35:01.786Z ERROR I SIS
2015-09-10T11:35:01.786Z ERROR I SIS Dumping action parameters from the script:
2015-09-10T11:35:01.786Z ERROR I SIS FilePath=["C:\Program Files (x86)\Symantec\Symantec Endpoint Protection\12.1.6168.6000.105\bin\EFAInst.exe"]
2015-09-10T11:35:01.786Z ERROR I SIS Parameters=["Symantec Endpoint Protection 12.1.6168.6000" /install /forcesingleinstance /resultcodeformat sis]
2015-09-10T11:35:01.786Z ERROR I SIS EnableCCTrace=[true]
2015-09-10T11:35:01.786Z ERROR I SIS OnError0=[PASS]
2015-09-10T11:35:01.786Z ERROR I SIS OnError1=[PASS]
2015-09-10T11:35:01.786Z ERROR I SIS OnError3010=[CATASTROPHIC_FAIL]
2015-09-10T11:35:01.786Z ERROR I SIS OnError3017=[FAIL_REBOOT_AND_ROLLBACK]
2015-09-10T11:35:01.786Z ERROR I SIS OnError606=[CATASTROPHIC_FAIL]
2015-09-10T11:35:01.786Z ERROR I SIS OnDefaultError=[FAIL]
2015-09-10T11:35:01.786Z INFO I SIS ExecuteScript() - Successfully set failure event.
2015-09-10T11:35:01.786Z INFO I SIS ExecuteScript() returning ACTION_FAILED_WITH_ROLLBACK

In EFASIInst-0x09F0.log:

2015-09-10-14-34-57-192 : EFASIInst : 0x09F0 : 0x2590 : Information : Opening service SymEFASI
2015-09-10-14-34-57-192 : EFASIInst : 0x09F0 : 0x2590 : Error : Failed to open service. winerror = 1060
2015-09-10-14-34-57-192 : EFASIInst : 0x09F0 : 0x2590 : Information : Problem finding existing version (winerror = 1060). This is likely a fresh install scenario
2015-09-10-14-34-57-192 : EFASIInst : 0x09F0 : 0x2590 : Information : Proceed with singleton install...
2015-09-10-14-34-57-192 : EFASIInst : 0x09F0 : 0x2590 : Information : Getting singleton actions...
2015-09-10-14-34-57-192 : EFASIInst : 0x09F0 : 0x2590 : Information : --> Starting SymEFA::GetSingletonActions...
2015-09-10-14-34-57-192 : EFASIInst : 0x09F0 : 0x2590 : Information : Filesystem supports ACLs. Create a DACL action for data folder
2015-09-10-14-34-57-192 : EFASIInst : 0x09F0 : 0x2590 : Information : --> Starting SymEFA::GetDesiredServiceStartType...
2015-09-10-14-34-57-192 : EFASIInst : 0x09F0 : 0x2590 : Error : Failed to open key. winerror = 2

2015-09-10-14-35-00-958 : EFASIInst : 0x09F0 : 0x2590 : Error : Failed to open key. winerror = 2
2015-09-10-14-35-00-958 : EFASIInst : 0x09F0 : 0x2590 : Information : Key not found
2015-09-10-14-35-00-958 : EFASIInst : 0x09F0 : 0x2590 : Information : <-- KernelSvcInstall::CRegKeyAction::uninstall ended
2015-09-10-14-35-00-958 : EFASIInst : 0x09F0 : 0x2590 : Information : --> Starting SymEFA::ProductIDReferencesExist...
2015-09-10-14-35-00-958 : EFASIInst : 0x09F0 : 0x2590 : Information : --> Starting SymEFA::AnyProductID...
2015-09-10-14-35-00-958 : EFASIInst : 0x09F0 : 0x2590 : Error : Failed to open key. winerror = 2

There are 2 kind of errors in this log:

Error 1060 = The specified service does not exist as an installed service. and WinError = 2 seems to mean that the installation program cannot find a file.

Cause

Customer has the Application Control program Lumension installed on the machine

Resolution

Disabling Lumension fixes the issue, some exceptions need to be made for the installation processes of SEP to be allowed by Lumension