How to increase the number of CCS Application Server & DPS Log files.
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How to increase the number of CCS Application Server & DPS Log files.

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Article ID: 162310

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Updated On:

Products

Control Compliance Suite Control Compliance Suite Standards Module Control Compliance Suite Standards Server

Issue/Introduction

You need to increase the number of log files on the Application Server as there is too much being logged, and information is being overwritten.

The number of the Application Server log files that are created by default was typically not enough for Development to determine problems, as so much information is logged that by the time the job finished, the information in the logs was overwritten and lost.  

Cause

As per the recommendation from CCS Development, the amount and size of the files for logging should be increased permanently.

Resolution

This can be done via some modifications in the AppserverService.exe.config file on the CCS Application Server. Perform the following steps.

  1. Close the CCS Console.
  2. Stop the Symantec Application Server Service.
  3. Go to the following location-<Install Dir>\Symantec\CCS\Reporting and Analytics\Application Server
  4. Find the AppserverService.exe.config file and open it in Notepad/Wordpad or preferably Notepad++.
    • Note make a backup of AppserverService.exe.config file before modifying it.
  5. Now, go to the <logging> section and at the end of that logging section if they don't exist add the following two keys, if they do update the value.
    • <add key="Log.FileLogger.MaxHistoricalLogfileSize_MB" value="800" />
    • <add key="Log.FileLogger.MaxHistoricalLogfileCount" value="80" />

      (This will allow the Application Server to create 80 App Server Log files of 10 MB each before overwriting the oldest log file)
  6. Save the AppserverService.exe.config file and restart the Application Server Service.

We will want to make the same changes to the Symantec.CSM.DPS.exe.config file on the CCS Manager(s) for LB and DC or Evaluator/Reporting Role, depending on what the issue is.

  1. On each of the CCS Manager Server(s) Stop the Symantec Data Processing Service. 
  2. Backup and remove the current logs at %ProgramData%\Symantec.CSM\Logs\CCSManager\
  3. On each of the CCS Manager Server go to the following location-<Install Dir>\Symantec\CCS\Reporting and Analytics\DPS\
  4. Find the Symantec.CSM.DPS.exe.config file and open it in Notepad/Wordpad or preferably Notepad++.
      • Note make a backup of Symantec.CSM.DPS.exe.config file before modifying it.
  5. Now, go to the <logging> section and at the end of that logging section if they don't exist add the following two keys, if they do update the value.
      • <add key="Log.FileLogger.MaxHistoricalLogfileSize_MB" value="800" />
      • <add key="Log.FileLogger.MaxHistoricalLogfileCount" value="80" />

        (This will allow the DPS Server to create 80 App Server Log files of 10 MB each before overwriting the oldest log file)
  6. Save the Symantec.CSM.DPS.exe.config file and restart the Symantec Data Processing Service.