InsufficientPriveledgeException when trying to check in/check out to/from Workflow project repository
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InsufficientPriveledgeException when trying to check in/check out to/from Workflow project repository

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Article ID: 162150

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Updated On:

Products

Workflow Solution

Issue/Introduction

When Workflow project is open and stays idle for some time, an attempt to check in to repository will throw an error InsufficientPriveledgeException.
Reloading the project will normally re-establish the connection to WorkflowRepositoryService on SMP and check-in will work again. Message :
Error getting repository project information
Symantec.Workflow.Manager.Common.Operation+OperationException: The server
operation failed with the following error: InsufficientPrivilegeException ---> System.ServiceModel.FaultException:
InsufficientPrivilegeException

Server stack trace:
   at
System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime
operation, ProxyRpc& rpc)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean
oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan
timeout)
   at
System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall,
ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage
reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData&
msgData, Int32 type)
   at
Symantec.Workflow.Manager.Repository.Proxy.IWorkflowRepositoryService.GetProjectById(String
SessionId, Guid projectId)
   at Symantec.Workflow.Manager.Repository.ServerGetProject.ExecuteAsync()
   at Symantec.Workflow.Manager.Repository.ServerOperation.BeginExecution()
   --- End of inner exception stack trace ---
   at
Symantec.Workflow.Plugins.Deploy.EntMan.MainForm.GetRepoProjectInfo(AbstractOrchestrationProject
project)


When capturing request to WorkflowRepositoryService with Fiddler we get 500 response and in SMP logs we can also see the following entries:
Checking Access Privilege for sessionId:'a91fe03b-c21b-499e-a74b-81698cb72056'
Process: w3wp (5564), Thread ID: 38, Module: w3wp.exe
Priority: 4, Source:
Symantec.Workflow.Web.Repository.WorkflowRepositoryService.CheckAccessPrivilege

Invalid SessionID
**CEDUrlStart**

:http://entced.symantec.com/entt?product=SMP&version=7.5.3153.0&language=en&module=/jgh5n3NrX8IjkmPk4jx4sWOKV4MSGSmjhtM7Cov5zk=&error=-645441301&build=**CEDUrlEnd**
Process: w3wp (5564), Thread ID: 38, Module: w3wp.exe
Priority: 1, Source: Symatec.Workflow.Platform.UserManagement.VerifySession
 

Cause

The error message is misleading while in reality we are dealing with expired session.
Symantec development is aware of the issue and the work is targeted towards next release.

Resolution

The current workaround is to save and reload the project before  check-in/check-out attempt.
In Workflow Designer click on File menu > Reload Project, on save prompt click Yes.