Agent Registration Policy Won't Allow Tasks to Execute in Automation
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Agent Registration Policy Won't Allow Tasks to Execute in Automation

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Article ID: 162123

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Updated On:

Products

Deployment Solution

Issue/Introduction

If the default agent registration policy gets disabled then any task that is being sent to a client while booted into WinPE Automation will not be recieved
or executed. In the PectAgent log the following error will be shown:
Failed to getPkgAccessCredentials from GetPackageSettings.aspx


In the NS logs (a.logs) the following error will be shown:
Failed to call task server method: RegisterClient
 

Cause

The Agent Registration Policy is set to disabled

Environment:
Deployment Solution 7.5 GA - 7.5 SP1 HF5
Deployment Solution 7.6 GA - 7.6 HF3
 

Resolution

By default the Agent Registration policy is enabled, however it is possible to turn it off.  To fix the issue make sure the policy is enabled.
It is located here Settings > All Settings > Symantec Management Agent > Settings > Registration Policies > Agent Registration Policy - Allow.