Unable to load specific MIB into the OID selection tool interface in the SNMP Data Mapping tables.
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Unable to load specific MIB into the OID selection tool interface in the SNMP Data Mapping tables.

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Article ID: 162113

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Updated On:

Products

Inventory Solution for Network Devices

Issue/Introduction

A customer is trying to import and use some Cisco MIBs to use with Network Discovery.
These MIBs consist of both “.mib” and “.my” files.

In the MIB Browser, “Settings > All Settings > Monitoring and Alerting > SNMP MIB Import Browser” he can import any of the “.mib” files.
And they are usable after the import.
However, if he tries to import any of the “.my” files it fails and presents the error message “Please select a valid MIB file” in the window.

If he uses the MIB Import task, “Manage > Jobs / Tasks > right click any folder > select New > Task > scroll down to and select “MIB Import” under Monitoring and Alerting”, he can import both the “.mib” and “.my” files.
They will both be imported into the “Program Files\Altiris\MibImportTask\Mibs\Uploaded” folder.

But if he tries to select one of the “.my” files within the “SNMP Data Mapping Tables”, “Settings > All Settings > Discovery and Inventory > SNMP Settings”, it will disappear from the window in a couple of seconds.
No errors are thrown.

It always defaults back to the "CISCO-ENTITY-VENDORTYPE-OID-MIB" entry.
This happens in about two to three seconds.

If he changes the name of the ".my" files to ".mib" they will import using either method.
However, those that were the ".my" files still cannot be used in the SNMP Data Mapping tables. Please select a valid MIB file.

Cause

The problem located, ComponentArt:TreeView contain about 5,7Mb data, but default limit is 4Mb.
This control is not our control, and it use a lot control symbols and each of them stored as Unicode (5 bytes), its do not use HTML compression (all variables have full names).
All data is needed to show content only and we do not need to post it back.

Resolution

The following work-around has been provided by our Developers:

Simple solution is increase Post request limit to 100Mb: in this file:
"C:\Program Files\Altiris\NetworkInventoryTask\Web\Web.config" inside Tag <system.web> add <httpRuntime maxRequestLength="102400" />.
This step is simple and possible to be done by support directly on client PC.