Accounts are being created automatically
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Accounts are being created automatically

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Article ID: 162089

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Updated On:

Products

IT Management Suite

Issue/Introduction

There are two problems that can occur:
  1. Accounts are created for computers, these will be created as COMPUTERNAME$
  2. Actual users are created as an Account and added to the Symantec Administrator Role, potentially giving them more rights that expected or desired

Cause

There are two possible causes:
  1. For computers being created as an account see TECH231057
  2. For Users being created as accounts and added to the Symantec Administrators.  There was a new feature added in 7.6 HF1 that will do this when a user is added to the local Administrator group on the Notification Server.

Resolution

There are two possible solutions:
  1. See TECH231057 for the ComputerName$ issue
  2. The behavior of users being created as a role and added to the Symantec Administrators, can be resolved by adding a custom setting that is not in 
    CoreSettings.config by default:
    • Open the CoreSettings.config file located at C:\ProgramData\Symantec\SMP\Settings
    • Add the following based on the desired functionality described below, the current default if nothing is defined is "2"

      <customSetting key="AutoCreateAccounts" type="local" value="0" />

      0 == do not automatically create accounts
      1 == automatically create accounts
      2 == automatically create accounts and add local admin accounts into the Symantec Administrator's role

NOTE: This will be changed to a default of 0 in Hot Fix 3 for 7.6 and beyond.