DS - PECTAgent.exe stops running in automation.
search cancel

DS - PECTAgent.exe stops running in automation.

book

Article ID: 162039

calendar_today

Updated On:

Products

Deployment Solution

Issue/Introduction

Clients that are booted into the automation environment fail to start the initial deployment menu, jobs and tasks.

Note: The 'Symantec Deployment Automation Agent is running - see logs here' window also terminates. Error message from automation environment X:\Program Files\Symantec\Deployment\Logs\PECTAgent.log file:

[2015/06/04 21:24:09.998 1708:1712 2] AgentGlobals.h:112 RegisterLibrary: LoadLibrary Failed to load x:\program files\Symantec\Deployment\AeXBasicInventory.dll
[2015/06/04 21:24:09.998 1708:1712 0] AgentGlobals.h:114 Agent Exception, Could not laod file ErrorCode=0, SystemError=6
[2015/06/04 21:24:09.998 1708:1712 2] PECTAgent.cpp:152 Stopping PECTAgent. Please check for Network configuration or server name resolving problem and try again.

Cause

'msi.dll' is missing in the 'X:\Windows\System32' directory.

Resolution

1) On the Notification Server only, download and replace any missing files in the following respective directories:

Attached 64-bit files should be placed under:
C:\Program Files\Altiris\Deployment\BDC\bootwiz\oem\DS\winpe\x64\Base\Windows\System32

Attached 32-bit files should be placed under:
C:\Program Files\Altiris\Deployment\BDC\bootwiz\oem\DS\winpe\x86\Base\Windows\System32

2) On the Notification Server under the Windows Task Scheduler Library, run 'NS.Package Refresh' to completion.

3) From the Symantec Management Console, navigate to Settings>Deployment>Manage Preboot Configurations. Select your desired preboot configuration and click 'Recreate Preboot Environment.'

4) Test booting a client into automation once bootwiz.exe is finished running on the designated NBS Server.

 

Attachments

Files.zip get_app