Inventory/SWM plug-in install/upgrade policy always shown with default name in Agent UI
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Inventory/SWM plug-in install/upgrade policy always shown with default name in Agent UI

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Article ID: 162037

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Updated On:

Products

Software Management Solution

Issue/Introduction

Article will cover scenario with SWM upgrade policy; same description and cause applicable to Inventory plug-in, etc.
For various reasons it may be required to clone the default "Software Management Solution Plug-in Upgrade" policy and rename the clone to be able to determine it later. When renamed policy will be applied on Windows client, in Agent UI > Software Delivery tab you will notice that
instead of having policy with actual name, you are seeing default name "Software Management Solution Plug-in for Windows (xx-bit)-Upgrade"
 
n/a

Cause

The cloned policy XML is having no values in string <displayname />.b Correct form is <displayName>XYZ</displayName>


Resolution

There is a workaround how to bring the names back via manually editing XML file.
If you open your plug-ins cloned policies for Inventory, Software, etc you will find several sections looking like following:
{94e404fe-086f-4948-969c-38234fae565e}
{266ff66d-e6b0-4608-8d4e-60056f09bf63}


Last display name value is exactly the one to be shown in UI. If it is missing, as now, then Software Management Solution Plug-in for Windows (64-bit) - Upgrade row is being used.

The simple workaround is to export policy, then edit XML file in some text editor, replace the missing row with the value of the policy and import back.
{94e404fe-086f-4948-969c-38234fae565e}
{266ff66d-e6b0-4608-8d4e-60056f09bf63}
XYZ, where the policy name is XYZ
After that, once it is deployed to any client, you should see new name in Software Delivery tab Policy column.

Above workaround may be tricky in case of large number of cloned policies for every solution plug-in. 

Issue is finally fixed in 7.6 HF3