My Task List report shows Priority as "Normal" irrespective of main incident priority
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My Task List report shows Priority as "Normal" irrespective of main incident priority

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Article ID: 161951

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Updated On:

Products

ServiceDesk

Issue/Introduction

On My Task List Page for all Users and Technicians, the report under My Task List shows the Priority of all Incidents as "Normal" irrespective of the main incident priority.

Cause

In SD.IncidentManagementSimple Workflow locked project the priority of a Task is hard coded as "Normal" instead of Incident Priority. This is considered as an enhancement request in next release.​

Resolution

By default, My Task List report is set to display "Tasks Viewer" report from Default category. This report is set to show the Priority of Task which is hard coded as "Normal" instead of Incident Priority. As a workaround, we can create a new report to show the priority of Process and edit My Task List Page to show this report.

To create the new report:
1. Login to Process Manager portal and click on Reports Tab
2. Select Default under Report category then click on Add Report and select Add Standard Report
(Note: When we create the report under Default Category, it will inherit the required permissions (Reports.Access from Report Category). It can be created under any other category but the required permissions needs to be added, otherwise it will give a permission error)
3. Provide a Name to the report, then click on select Data Source, leave it Default and click on ok.
4. On left side Data, select Add Processes To Report under Process Management then select Add Processes to Report & Report Process ID.
5. Scroll down, select Add Tasks To Report under Tasks then select Assigned To Me, Include Task Actions & Completed​ under Tasks.
6. Add the required Columns from right side, like Priority, Project Name, Process Name, Age Description, Report Process ID under Process and WFTask Numbe​r under Task. Rename the colums, if you want and save the report.
7. Run the report to verify if you are getting the required details.

To edit My Task List page:
1. Login to ServiceDesk portal with admin rights, go to My Task List, click on Site Actions>Modify Page, again click on Site Actions>Edit Page.
2. Click on Edit next to My Task List, select the Newly created report under 
Report Selection. Then click on Apply and OK.
3. Now go to My Task List and it will show you this report.