Custom Filters do not Appear in Apply to>Quick Apply Menu in Policies in 7.6
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Custom Filters do not Appear in Apply to>Quick Apply Menu in Policies in 7.6

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Article ID: 161916

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Updated On:

Products

IT Management Suite

Issue/Introduction

Custom Filters can not be selected in the on the Policy > Apply to > Quick Apply Menu in ITMS 7.6. Affected policies include Software Update policies and Managed Software Delivery policies.

The old applicable method was as follows in previous versions allowing target for Group, Filter or Targets to apply:

The new applicable method in v7.6 is as follows and excludes targeting anything other than the Default Targets:

Cause

The product is working as designed, for the 'Apply to' > 'Quick Apply' menu in ITMS 7.6 no longer allows for selecting of Group or Filter and only displays applicable Targets, for there were anomalies found in older versions which allowed underpriviledged users the ability to target entire environments with a Policy via Filters; however, the Targets are scoped to allow users to target only what they have rights to.

Resolution

The Filter may still be targeted by working through the following on the Policy:

  • 'Apply to' > 'Computers'
  • Specify the 'exclude computers not in' drop down
  • Specify the 'Filter' drop down
  • Specify the 'Custom Filter' name
  • Click on 'Update results' to list 
  • Click 'OK' to save Target


However the best practices method to target a custom filter in 7.6 is to create a target from the Custom Filter.

  • Go to the Console > Manage > Computers
  • Drill down under the 'Filters' segment and isolate the Custom Filter
  • Highlight the Custom Filter > Right-click > Create Target from Filter
  • Name the Target with the same name or give it a new name
  • Click 'OK' to save the Filter as a Target

  • The 'Quick Apply' will then list the Target with the same or new name of the Custom Filter as created above:

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