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Article ID: 161888
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Updated On:
Issue/Introduction
After upgrading from Symantec Management Platform (SMP) 7.5 to 7.6 the Site Server and client upgrade packages are corrupted and current 7.5 version endpoints will not upgrade to the 7.6 version.
"4/9/2015 8:36:28 AM","End download for package: Symantec Management Agent Package {47E1F709-5EF8-44EA-9A1A-955620A09ED4}. Status: retrying","PackageDelivery","AeXPackageDelivery.dll","968","Informational"
"Unable to refresh the codebase information for package: 'Symantec Management Agent Package' (47e1f709-5ef8-44ea-9a1a-955620a09ed4)
Could not access the package path. Package: 'Symantec Management Agent Package' (47e1f709-5ef8-44ea-9a1a-955620a09ed4), Path: C:\Program Files\Altiris\Notification Server\NSCap\Bin\Win32\X86\NS Client Package"
Cause
Unsure at this time. Something about the upgrade to 7.6 corrupts the Symantec Agent Package and/or software resource.
Resolution
You'll need to export either the x86 and x64 agent packages (depending on which version is not upgrading) from a 7.6 lab and import into the customer's NS. To do this:
- Navigate to Manage>All Resources>Package in the Console.
- Search for "Symantec Management Agent" and select the package that you need in the customer's environment.
- Right-click and select "Export". Follow the prompts to save the .xml file in a location of your choosing. *Repeat these steps for both packages if needed*
- Transfer your .xml file to the Customer's SMP server, then navigate back to Manage>All Resources>Package in the Console.
- Right-click on the root of Package in the tree view on the left, and select "Import". Then navigate to where you placed the .xml file imported from your lab, click "OK"
- You'll see a prompt stating "The item you are importing already exists in the system under a different folder. Importing the item will move it to this folder. Press OK to continue the import or Cancel to abort.". Click "OK" to finish importing the package.
Note: In one instance the customer had the SMP installed on E: and not the default location so we had to export the .xml, modify the path to reflect the customer's install path, and then import that modified .xml back into the Console. You'll clearly see the error about path when NS.PackageRefresh runs in the SMP logs. "Unable to refresh the codebase information for package: 'Symantec Management Agent Package' (47e1f709-5ef8-44ea-9a1a-955620a09ed4) Could not access the package path. Package: 'Symantec Management Agent Package' (47e1f709-5ef8-44ea-9a1a-955620a09ed4), Path: C:\Program Files\Altiris\Notification Server\NSCap\Bin\Win32\X86\NS Client Package"
- After importing the package/s open up Task Scheduler on the SMP server and run NS.PackageRefresh and NS.DistributionPointUpdate to recreate the codebase for the package/s.
- Once NS.PackageRefresh has completed the Package Servers should be able to download the correct codebase and package now. You can wait for the PS to do this on schedule or manually update configuration to prompt the download.