Client machines are returning an error http 400. Issue with checking in clients: Bad Request - Invalid Verb
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Client machines are returning an error http 400. Issue with checking in clients: Bad Request - Invalid Verb

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Article ID: 161839

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Updated On:

Products

IT Management Suite

Issue/Introduction

Customer reported that this issue start occurring with his Windows Surface Pro 8.1 machines which has Update 1. 

In his agent logs he's receiving a http 400 - Bad Request error:

Process: AeXNSAgent.exe (4956),
Module: AeXNetComms.dll
Priority: 1,
Source: NetworkOperation

Error note: 400 Bad Request: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN""http://www.w3.org/TR/html4/strict.dtd">;
<HTML><HEAD><TITLE>Bad Request</TITLE>
<META HTTP-EQUIV="Content-Type" Content="text/html; charset=us-ascii">
</HEAD>
<BODY><h2>Bad Request - Invalid Verb</h2>
<hr><p>HTTP Error 400. The request verb is invalid.</p>
</BODY></HTML>

Error message: Error 0x80042D21 (No description available) 

 

 

With these errors occurring, basic inventory is not sent nor configuration requests updated.

These are 3 errors that we have noticed in a regular basis:
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Error 1:
Operation 'Post' failed.
Protocol: http
Port: 80
Path: /Altiris/NS/Agent/CreateResource.aspx
Http status: 400
Secure: No
Id: {E00392C3-3546-48E2-B8A7-DA7837F12B57}
Error type: HTTP error
Error result: 0x80042D21
Error code: 400
Error note: 400 Bad Request: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML
4.01//EN""http://www.w3.org/TR/html4/strict.dtd">; <HTML><HEAD><TITLE>Bad Request</TITLE> <META HTTP-EQUIV="Content-Type" Content="text/html; charset=us-ascii"> </HEAD> <BODY><h2>Bad Request - Invalid Verb</h2> <hr><p>HTTP Error 400. The request verb is invalid.</p> </BODY></HTML>

Error message: Error 0x80042D21 (No description available)

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Error 2:
Operation 'Post' failed.
Protocol: http
Port: 80
Path: /Altiris/NS/Agent/PostEvent.asp
Http status: 400
Secure: No Id: {430E8A5E-957B-405A-95B5-94D0CAF25CFE}
Error type: HTTP error
Error result: 0x80042D21
Error code: 400
Error note: 400 Bad Request: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN""http://www.w3.org/TR/html4/strict.dtd">; <HTML><HEAD><TITLE>Bad Request</TITLE> <META HTTP-EQUIV="Content-Type" Content="text/html; charset=us-ascii"> </HEAD> <BODY><h2>Bad Request - Invalid Verb</h2> <hr><p>HTTP Error 400. The request verb is invalid.</p> </BODY></HTML> 

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Error 3:
Operation 'Post' failed.
Protocol: http
Port: 80
Path: /Altiris/ClientTaskServer/Register.aspx
Http status: 400
Secure: No Id: {6930AA0F-75E1-42F3-ADAD-AC064DAEB472}
Error type: HTTP error
Error result: 0x80042D21
Error code: 400
Error note: 400 Bad Request: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN""http://www.w3.org/TR/html4/strict.dtd">;
<HTML><HEAD><TITLE>Bad Request</TITLE>
<META HTTP-EQUIV="Content-Type" Content="text/html; charset=us-ascii">
</HEAD>
<BODY><h2>Bad Request - Invalid Verb</h2>
<hr><p>HTTP Error 400. The request verb is invalid.</p>
</BODY></HTML>

Error message: Error 0x80042D21 (No description available)

Cause

Known issue. In some situations on SurfacePro machines the POST headers are lost between Windows API and the network card.

Resolution

This issue has been reported to our Symantec Development team. A fix for this issue has been planned with ETA of ITMS 7.6 HF1.

A pointfix is available for those customers with ITMS 7.5 SP1 HF5. See attached file called "Pointfix_eTrack3649134_7_5_SP1_HF5.zip"

 

MINIMUM REQUIREMENT:

Installed SMP 7.5 SP1 HF5  

HOW TO INSTALL THIS POINTFIX:  
1. Log in as administrator
2. Retrive files from the archive to the NS hard drive.
3. Click on PFinstaller.exe
4. Click install files button
5. From Windows Task Scheduler run NS.Package Distribution Point Update Schedule and NS.Package Refresh.
6. Upgrade SMA on clients via SMA upgrade policy for non-site servers. New SMA version 7.5.3305  

CHANGES MADE:  
Added 1 ms pause before sending request to socket as workaround.  

HOW TO UNINSTALL THIS POINTFIX  
1. Log in as administrator
2. Retrieve files from the archive to the NS hard drive.
3. Click on PFinstaller.exe
4. Click uninstall files button  

 

This hotfix has the following known issues:

 None.


  

 


Applies To

ITMS 7.5 SP1

Attachments

Pointfix_eTrack3649134_7_5_SP1_HF5.zip get_app