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WAIK folder issues cause problems in Deployment Solution

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Article ID: 161825

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Updated On:

Products

Deployment Solution

Issue/Introduction

It has been documented that ocassionally for unknown reasons the Windows ADK does not download/install properly and items in the WAIK folder that comes with the package are missing or of incorrect file size.

The errors seen can vary depending on what is missing from the waik file. The dstasks log in automation may not be generated, It may show failing WMI calls in dstasks logs, or it may show other issues not listed here.  The main issue that can be seen is that the client will not receive tasks while in automation even though the client seems to be registered with a task server.  So a boot to pxe task will run,but then a caputre or deploy task will quickly fail.

Cause

The cause of this issue is unknown at this time.  It appears to be a problem with the Microsoft ADK download or installation.  Symptoms include the following and possibly other issues:

C:\Program Files\Altiris\Deployment\BDC\waik\Tools\PETools\amd64\winpe.wim is too small.  File size should be 191,047 KB.  Sometimes this can show up in the 170,000 KB range.
C:\Program Files\Altiris\Deployment\BDC\waik\Tools\PETools\x86\winpe.wim is too small.  File size should be around 157,681 KB.  Sometimes this can show up in the 130,000 KB range.

C:\Program Files\Altiris\Deployment\BDC\waik\Tools\PETools\amd64\WinPE_FPs folder is missing. 
C:\Program Files\Altiris\Deployment\BDC\waik\Tools\PETools\x86\WinPE_FPs folder is missing.

Resolution

Assuming the current installed product is DS 7.5 SP1 HF5 or prior, please read the following documents and install the pointfixes listed prior to following the rest of the steps. These issues listed in the following documents are current up to HF5.  Since the solution in this document requires that the preboot environments be rebuilt and distribution point update, and NS package refresh tasks be run, it is best to install the point fixes listed in these documents as well so it can all be done in one shot.  Please see the following documents:


http://www.symantec.com/business/support/index?page=content&id=TECH228110
http://www.symantec.com/business/support/index?page=content&id=TECH227363

After the pointfixes listed in the documents above have been installed please use the following steps to replace the waik folder.

1.)  Please contact Symantec Technical Support for instructions on how to obtain a known good WAIK folder.
2.)  Once you have obtained a known good WAIK folder, back up the existing WAIK folder located on the NS here: 
      C:\Program Files\Altiris\Deployment\BDC\waik and move the current one to a location that is not within the Altiris folder structure.
3.)  Place the known good WAIK folder in the same folder the old one was removed from C:\Program Files\Altiris\Deployment\BDC.
4.)  Be aware of where the pxe server is located in the environment.  If there is only one on the NS then you don't need to worry about having the BDC package download to site servers. If the PXE server is located on Site Servers or both NS and Site Servers then you need to pay attention to wether or not the BDC package   has finished downloading on the site server.
5.)  On the NS go to Start and search for the Task Scheduler program.
6.)  Once the Windows Task Scheduler program is open click on the Task Scheduler Library icon in the tree view in the left pane and a list of all tasks will be listed in the middle pane.
7.)  Scroll down the list and find and run the following two tasks: NS.Package Distribution Point Update Schedule, NS.Package Refresh.  This will trigger the SS to start downloading the BDC package.
8.)  If using a Site Server as a PXE server make sure to let the BDC package finish downloading before proceeding to rebuilding the preboot environments.  To check the status of the BDC package download logon to your Site Server and open up the Symantec Management Agent interface.  Click on the Package Server tab and look for the BDC package and it will show the download status.
9.)  Once the SS has finished downloading the BDC package rebuild the preboot environments by opening up the console on the NS and navigating to the following page: Settings > Deployment > Create Preboot Environments
10.)
Select the preboot environment you would like to use for your deployment/capture jobs and click Recreate Preboot Environments.
11.) Make sure bootwiz32.exe starts running and completes before trying to run any jobs. Bootwiz will run on the pxe server and you can see it running in the Windows Task Manager under processes.
12.) Try to deploy or capture an image.

 

Applies To

 

DS 7.5 SP1 HF4
DS 7.5 SP1 HF5
DS 7.6
WinPE 4.0