search cancel

After a hotfix is applied, Ghost and DeployAnywhere files are not updated in the SBS OEM folder structure

book

Article ID: 161681

calendar_today

Updated On:

Products

Deployment Solution

Issue/Introduction

When a hotfix is applied to a system that contains updates to Ghost and DeployAnywhere files, customers need to recreate their SBS preboots to include the updated files.  A defect has been discovered in the SBS build process where the Ghost and Deploy Anywhere files do NOT get updated in the SBS directory paths(see below) as they should and therefore do NOT get included in the SBS preboots:

 

C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\SBS\Bootwiz\ {374E1C49-4F58-4F5C-8D51- 07A30F0D44AD}\cache\bootwiz\oem\DS\winpe\x64\Base\Program Files\Symantec\Deployment

C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\SBS\Bootwiz\ {374E1C49-4F58-4F5C-8D51- 07A30F0D44AD}\cache\bootwiz\oem\DS\winpe\x86\Base\Program Files\Symantec\Deployment

 

Since the updated files do not get copied to the aforementioned directories, customers SBS preboots will contain old Ghost and DeployAnywhere which can cause numerous issues with UEFI and Surface Pro 2/3 systems.

No error is displayed in the UI or in any logs when this occurs.  Customers may note that Ghost doesn't properly work with UEFI systems and that DA doesn't work properly with USB 3.0 drivers.

Cause

SBS code was not copying files to the aforementioned directories.

Resolution

 

Run attached PFInstaller to install the pointfix on your NBS Servers. Then rebuild your PXE environments.

 

 

Applies To

All DS 7.5 builds up to and included DS 7.5 SP1 HF5

Attachments

PFInstaller_3716209.zip get_app