Unable to Remote Manage Windows Mobile or CE Devices

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Article ID: 161598

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Updated On:

Products

Mobile Management

Issue/Introduction

When managing Windows Mobile or Windows CE devices with Symantec Mobile Management and from a "remote browser", you are unable to connect to the device through the "Remote Management" window.  The Remote Management window appears off-line and does not display a device name. 

If you log onto the Symantec Mobile Platform server and browse to the same device, the Remote Management window displays as online and can be managed.

Altiris Diagnostic event logs may indicate multiple instances of the following error:

"Error getting device info for remote management home page.  Failed to construct DatabaseContext object. Connection to database failed."
 

Cause

This issue is caused by a combination of environment deployment configuration and an incorrect IIS configuration file for the Remote Management page.  The Remote Management problem occurs when:

  • SMP and SQL are on separate servers.
  • Administrator is browsing to the Altiris console from a host which is not the SMP server itself.

The web.config file in the Remote Management application folder provides incorrect authentication details.  This causes the Remote Management function to fail when both of the above conditions are true.  The impersonated Altiris credentials are not used and the logged-in user is unable to access the database for this page.

Resolution

This issue is targeted to be resolved in a future release.

As a work-around, you can do the following:

  1. Log onto the Symantec Management Platform server.
  2. Go to "C:\Program Files\Altiris\MobileManagement\Web\Remote Management".
  3. Rename the "web.config" file to "web.config.old".
  4. Refresh the remote browser.

 


Applies To

Symantec Management Platform - dedicated server

Microsoft SQL Server - dedicated off-box server

Symantec Mobile Management installed with SMP

Windows Mobile / CE devices