Patch Management Agent fails to run custom applicability check
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Patch Management Agent fails to run custom applicability check

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Article ID: 161576

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

The Software Update Agent is unable to run a custom applicability check prior to install an update. As a result software updates remain in
pending state.

<Event> source='AssessmentTool' module='PatchMgmtAgents.dll' process='AeXNSAgent.exe' 
 [Package {6D417916-467C-46A7-A870-6D86D9345B61} is invalid]]>Event>

<Event > source='SoftwareUpdateAgent' module='PatchMgmtAgents.dll'
process='AeXNSAgent.exe' pid='9764' thread='7472' tickCount='-254236201' >
  <![CDATA[Failed to run assessment tool]]>Event>

 

Cause

In some instances the software update agent fails to synchronize with the symantec management agent and and is unable to validate the assessment scan package located in C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{6D417916-467C-46A7-A870-6D86D9345B61}\cache’.
 

Resolution

Software Update Plug-in logic has been modified to wait until assessment tool package
is downloaded (with 10 seconds timeout), in case the package is not ready during custom
applicability check.
 

Apply the attached Point Fix to get the the new version of the Software Update Agent for 7.5.

7.6 Agent already contains the fix.

Attachments

7.5_SP1_PM_PF_3667567.zip get_app