Getting HTTP Error 500 when viewing Internal NS Schedules and All Server schedules for the Internal Schedules Calendar
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Getting HTTP Error 500 when viewing Internal NS Schedules and All Server schedules for the Internal Schedules Calendar

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Article ID: 161557

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Updated On:

Products

IT Management Suite

Issue/Introduction

Customer is getting an error while trying to load the "Internal NS Schedules" and "All Server schedules" views for the 'Internal Schedules Calendar' page (under Settings>All Settings>Notification Server). 

 

 

This is the message displayed:

 

Cause

This issue is caused by 2 schedules:
'Default Synchronize Security Roles Task' (e2830df2-f93f-450a-b5d5-921e01f02540) 
and 
'Default Processing Task' (3235ec0d-423a-47a9-834f-ee44a4aada10)

If one or both of those are enabled, the error http 500 will be displayed.

Looking at the profile trace, under "rawUrl: /Altiris/NS/Services/CalendarWebService.asmx", you should see the following error entry: 
ScheduleInforResult\WriteXml : T+1434.7, Tn+0000.0, 0001.6 ('Default Synchronize Security Roles Task' (e2830df2-f93f-450a-b5d5-921e01f02540))
which is generating the following exception: 
exceptionCode: C0000005 or a similar exception value.

The problem seems to be related to invalid entries for those schedules.

Resolution

This issue should be addressed by the Symantec Development team in a later release. Currently targeted for ITMS 7.6.

A pointfix is available for those in ITMS 7.5 SP1 HF3. See attached file "Pointfix_eTrack3688386_ITMS_7_5_SP1_HF3.zip"

 

APPLICABILTY  REQUIREMENT:
SMP 7.5 SP1 HF3

 

HOW TO INSTALL THIS POINTFIX:

  1. Extract files from the archive to the NS hard drive. Make sure Point Fix is not extracted to Altiris install directory (or any subfolder to it).
  2. Execute PFInstaller.exe with administrative privileges (right-click > Run as administrator). Select "Install Files".
  3. Accept UAC (User Account Control) if prompted, select Install Files. Old binaries will be automatically backuped to the Backup folder at the same location where PFinstaller is and replaced with the new ones. Log-file Log.txt will be created at the same location where PFinstaller is.
  4. Close PFInstaller window.

 

HOW TO UNINSTALL THIS POINTFIX:

     1. Make sure that Backup subfolder is located in PFinstaller directory

  1. Execute PFInstaller.exe with administrative privileges (right-click > Run as administrator). Old binaries will be repaired from Backup folder located at the same location where PFinstaller is. NS services should be started automatically.
  2. Accept UAC (User Account Control) prompt, select Uninstall Files.
  3. Close PFInstaller window.

 

CHANGES MADE :

  1. Changes made Altiris.NS.UI.dll.

 

 

There are two workarounds available for those that don't want to apply the pointfix or have a different SMP 7.5 SP1 version installed:

1. Disable the following schedules (if they are enabled):
'Default Synchronize Security Roles Task' can be disable under Settings>All Settings>Notification Server>IT Analytics Settings>Cubes. Go to the Security tab and uncheck 'Enabled'. Save changes. 
'Default Processing Task' can be disable under Settings>All Settings>Notification Server>IT Analytics Settings>Processing. Uncheck 'Enabled'. Save changes. 

2. Run the updated stored procedure attached to this KB called "spCalendarSelectScheduledItemsByOccurrenceDateRange_Modified.sql". Basicaly this stored procedure will exclude schedule item from ITAnalytics for been display on the 'Internal Schedules Calendar' page. In this way these two schedules can be enabled and used until a fix is provided.


Applies To

ITMS 7.5 SP1 and later
IT Analytics 7.5

Attachments

spCalendarSelectScheduledItemsByOccurrenceDateRange_Modified.sql get_app
Pointfix_eTrack3688386_ITMS_7_5_SP1_HF3.zip get_app