Inbound email delays to on-premises Exchange server
search cancel

Inbound email delays to on-premises Exchange server

book

Article ID: 161395

calendar_today

Updated On:

Products

Email Security.cloud

Issue/Introduction

If you experience issues with general or intermittent inbound email delays from the Symantec Email Security Service, where you are using a Microsoft Exchange Server based on-premises configuration and the outbound traffic is not affected, this is most likely due to a service of the Exchange server called back pressure. Back pressure is a feature that monitors resources such as free disk space and the memory available on the system.

If one or more of the resources being monitored hits a predefined limit, Exchange will then stop the inbound mail-flow, providing temporary SMTP errors to inbound connections. This will not have any effect on the ability to send emails outbound. 

Symptoms of back pressure causing email delays:

  • Your users cannot receive inbound emails.
  • The Exchange server appears to be running fine and there are no outbound mail issues.
  • Restarts on the server do not resolve the issue and no errors are found on the event logs.
  • Email Track and Trace tool results show that inbound emails are retrying with the response from your server 4.3.1 Insufficient System Resources.
  • Senders are receieving NDRs reporting temporary delivery failures referencing the error 4.3.1 Insufficient system resources.
 

452 4.3.1 Insufficient system resources

Environment

Customer using an on-premises type email hosting solution, based on Microsoft Exchange Server

Cause

Low Disk Space on the drives hosting Microsoft Exchange services

Low System Memory

Resolution

NOTE: The solutions in this scenario are related to the configuration and management of the on-premises Microsoft Exchange Server solution.

Possible solutions in this scenario are:

  • Identify the resources which trigger the back pressure mechanism and take actions to make more of them available
  • Modify the back pressure thresholds, allowing the continued operation of the Exchange server within the same environment
  • Disable the back pressure feature

For specific details regarding your particular Exchange implementation, please reference the following official Microsoft articles: