ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Error displaying "Unable to get the Database Schema Version" when upgrading Symantec Endpoint Protection Manager

book

Article ID: 161385

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

When upgrading the Endpoint Protection Manager, you receieve an error saying that the Management Server Upgrade Wizard is unable to get the Database Schema Version.  Has been observed in 12.1 RU5 and newer, including SEP 14.0.

From Upgrade-0.log : com.sygate.scm.server.metadata.MetadataException: Invalid object name 'BASIC_METADATA'.

From scm-server-0.log: org.apache.tomcat.dbcp.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (Invalid object name 'CONNECTION_TEST'.)

Cause

The SEPM DB user account (Normally 'sem5') had the sysadmin privilege set.

 

Resolution

 

1) Uncheck the "sysadmin" rights for sem5, in the Microsoft SQL Server Management Studio:


2) Ensure that sem5 is a dbo for the SEPM database.

3) Re-run the upgrade wizard.

 

Applies To

 

SEPM versions 12.1 RU5 and higher.

Attachments