Error: “Failed to deserialize ruleset – Could not find type Symantec.ServiceDesk.Im.Automation.Actions.SendImNotificationForTaskEventsAction.
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Error: “Failed to deserialize ruleset – Could not find type Symantec.ServiceDesk.Im.Automation.Actions.SendImNotificationForTaskEventsAction.

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Article ID: 161243

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Updated On:

Products

ServiceDesk

Issue/Introduction

 After updating to a revised Symantec.ServiceDesk.Im.Automation.dll file, the following error was received:

“Failed to deserialize ruleset – Could not find type Symantec.ServiceDesk.Im.Automation.Actions.SendImNotificationForTaskEventsAction.

 “Failed to deserialize ruleset – Could not find type Symantec.ServiceDesk.Im.Automation.Actions.SendImNotificationForTaskEventsAction.

Cause

The dll contained the older class references contained in the error message, specifically the  "...Actions.SendImNotificationForTaskEventsAction" class. The version of the Symantec.ServiceDesk.Im.Automation.dll which was provided as an update must have been an old, outdated version,  inadvertently provided.

Resolution

 A version of the Symantec.ServiceDesk.Im.Automation.dll file, version 7.5.3000.170, dated 9/9/14 is in KB TECH 212326, found here.  Please follow the instructions containedin the KB article to replace the Symantec.ServiceDesk.Im.Automation.dll accordingly.


Applies To

 Servicedesk 7.5 Sp1