Can not access the console or start the service after modifying a Symantec Protection Engine configuration file
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Can not access the console or start the service after modifying a Symantec Protection Engine configuration file

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Article ID: 161097

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Updated On:

Products

Protection Engine for Cloud Services AntiVirus for Caching Protection Engine for NAS

Issue/Introduction

A modification has been done to a Symantec Protection Engine (SPE) configuration file e.g configuration.xml, filtering.xml, liveupdate.conf, liveupdate.xml by directly editing the configuration file with notepad or any other non xmlmodifier application.
 

Cause

The configuration file has been edited with a non-xmlmodifier application and has lost the java parameters.
 

Resolution

Before editing any SPE configuration file pls ensure you back up the existing configuration file.
It is necessary to use the xmlmodifier application shipped with Symantec Protection Engine.
Since we can not guarantee configuration file format consistency when using any other method to modify the SPE configuration files.

For SPE 7.0.x
java -jar xmlmodifier.jar -s XML_PATH

For SPE 7.5.x
xmlmodifier.exe -s XML_PATH

At this time the only confirmed solution is to reinstall Symantec Protection Engine.
In most cases restoring the original xml file and restarting the scan engine service will restore the service and console access.

 


Applies To

Symantec Scan Engine 5.2.x
Symantec Protection Engine 7.x