Change Altiris Site/Package Server IP Address - PXE Boot

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Article ID: 161044

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Updated On:

Products

Management Platform (Formerly known as Notification Server) Deployment Solution

Issue/Introduction

Moving a Package server with Network Services PXE Boot changes the IP address of the Server.

Cause

The package server itself doesn't care about the IP Address change. But PXE requires the IP address to be updated in order to do the network start up. If the IP is wrong, it will be unable to PXE boot a resource.

Resolution

After the Static IP has been configured:
 
Stop all four NetBoot Services
Change IP address in C:\Altiris\Altiris Agent\Agents\Deployment\Task Handler\SBS\initialPXEConfigPath.txt file
Delete contents of C:\Altiris\Altiris Agent\Agents\Deployment\Task Handler\SBS\SBSStore
Delete contents of C:\Altiris\Altiris Agent\Client Policies
Change IP Address from Old to New in “sbs_serverlist” SQL Table
Start all four NetBoot Services
Update Altiris Agent
Check initialPXEConfigPath.txt file for correct IP address.  Make sure the agent has received a change after you requested one at step 7.
 
 
SQL:
 
select * from sbs_ServerList       (lists everything in the table)
 
Then Run:
 
Update sbs_ServerList
 
SET IPAddress='198.162.129.18'
 
WHERE Guid='69EC137D-7146-45E5-8F72-35460BF2584F'
 
(Swapping the desired IP and the correct GUID)