LiveUpdate Administrator version 2.3.3 installer reports no errors but LUA PostgreSQL service is not installed

book

Article ID: 161036

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

LiveUpdate Administrator version 2.3.3 installer reports no errors but LUA PostgreSQL service is not installed, cannot log onto LUA web site.

Cause

LUA 2.3.3 PostgreSQL requires Microsoft Visual C++ 2010 32-bit redistributable and this is normally installed along with LUA. If the 64-bit version of the redistributable is installed (but not the 32-bit version), then the LUA installer apparently skips the installation of the 32-bit version.

Resolution

Uninstall LUA, manually install Microsoft Visual C++ 2010 32-bit redistributable, and re-install LUA.