SMTP Code: "421 4.4.0 [internal] failed to connect: no mail servers for this domain could be reached at this time"
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SMTP Code: "421 4.4.0 [internal] failed to connect: no mail servers for this domain could be reached at this time"

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Article ID: 161032

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Updated On:

Products

Messaging Gateway

Issue/Introduction

You have noticed that the Messaging Gateway cannot deliver some outbound emails. These emails stay in the delivery queue with the message "421 4.4.0 [internal] failed to connect: no mail servers for this domain could be reached at this time."

Message Audit Log shows:

Error 421 4.4.0 [internal] failed to connect: no mail servers for this domain could be reached at this time.
Attempted Delivery to: default-non-local-route

Delivery queue shows:

Route: default-non-local-route
Last error: Error 421 4.4.0 [internal] failed to connect: no mail server for this domain could be reached at this time.

Cause

This message may be caused by a number of different situations. Some typical examples are:

  • The destination mail server is unreachable or offline
  • Firewall rules are preventing the IP address used to deliver outbound email to the internet is not allowed by the local firewall

Resolution

To investigate this issue:

  1. Confirm SMTP connectivity to the internet and the destination mail server / domain
  2. Ensure that firewall rules allow the IP / interface specified in SMTP Delivery Bindings is allowed to connect to the internet on port 25

Confirm SMTP connectivity to the destination mail server / domain:

A telnet test from the SMG admin command line may be used to confirm whether SMG is able to connect to the destination mail server. Please see Troubleshoot email delivery issues using telnet for a detailed description of how to test SMTP connectivity and delivery via the telnet command.

Confirm that the SMG IP / interface for non-local mail in SMTP Delivery bindings can connect to the internet:

See SMTP advanced settings for delivery bindings.

Applies to

  • Scanner with two IP addresses; one IP address for inbound connections, and the other IP address for outbound connections.
  • The Advance SMTP configuration shows: Non-local messages: Auto
  • The SMG inbound IP is not allowed to reach the remote domain (firewall rejects the connection, for example).

Additional Information

For complete details on how to test mail delivery issues, reference the section, "Outbound messages in the delivery queue are not being delivered" in the document, Troubleshoot email delivery issues using telnet

It can also be that there is connectivity but the target server is replaying back "please try again later". It is advised to check if reputation for the sender domain is not blacklisted.