All Notification Server (NS) agents fail to communicate with NS including NS agent
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All Notification Server (NS) agents fail to communicate with NS including NS agent

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Article ID: 160947

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Updated On:

Products

IT Management Suite

Issue/Introduction

All NS agents fail to communicate with NS including NS agent. Not able to recieve policies, or post any NSEs.  The following errors are seen in the logs:

"7/14/2014 1:47:56 PM","RequestPolicies failed: HTTP status: 0. Invalid data received in HTTP response. Expected 33 bytes, received 0 (0x8007000D)","ConfigServer","AeXNSAgent.exe","11828"

"7/14/2014 1:47:56 PM","Post to 'http://NOTIFICATION-Server.local/Altiris/NS/Agent/GetClientPolicies.aspx' failed: HTTP status: 0. Invalid data received in HTTP response. Expected 33 bytes, received 0 (0x8007000D)","AeXNetworkTransport","AeXNSAgent.exe","11828"

"7/14/2014 1:47:56 PM","HTTP status: 0. Invalid data received in HTTP response. Expected 33 bytes, received 0 (0x8007000D)","AeXNetworkTransport::raw_PostResponseBinary","AeXNSAgent.exe","11828"

Environment

ITMS 8.x

Cause

HTTP-KeepAlive was disabled, once enabled communication started to continue.

Http-keep alive is required because the agent follows the head method with the post, while IIS was terminating the connection, causing the error on agent side (0 length response)

Upon checking the TCP-stream for GetClientPolicies.aspx from a client, we found that the connection was closed from server side just after the head method from client, causing the server not to respond to the followed post method in the same stream.

Resolution

Turned on Http-KeepAlive found in:

IIS manager, Default Web Site, HTTP Response Headers, Set Common Headers: Check box "Enable HTTP Keep-Alive"